Go Back   The Scream! > COMPUTER RELATED > General Software

Reply
 
Thread Tools Display Modes
  #1  
Old 25-January-2002, 23:21
squidgy
Guest
 
Posts: n/a
Default Windows file type program association .... help!

I hate having to ask such silly questions but there we go, I'm having a problem.

I've got a scripting language interpreter called "Rebol Core", and I want to associate files with the .r extension with this program, so that when I double click them, they open in Rebol Core. This used to work in the past, but it doesn't now.

Instead, what happens is the Rebol Core program starts, but it doesn't actually open the file.

The same thing happens if I try to do START file.r from an MSDOS prompt.

However, I tried changing my autoexec.bat file so that the directory with the Rebol Core executable is in the PATH list. So now, if I do REBOL file.r from an MSDOS prompt, that DOES work. Also I tried putting a shortcut to the Rebol Core executable in my Send To folder, and right clicking files and selecting the shortcut .... that works too.

So the executable clearly accepts a file as a parameter and opens it. So why won't it work properly just by double clicking or using the START command in MSDOS? I probably need to change something in the file associations, but I have absolutely no idea what's wrong. Thanks.
Reply With Quote
  #2  
Old 25-January-2002, 23:30
silver's Avatar
silver silver is offline
 
Join Date: Apr 2001
Location: Bournemouth, UK
Posts: 12,177
Default

to set up file associations..

goto 'my documents' (or any folder really) click 'View' > 'Folder Options...'

then the far right tab 'file types'

you need to scroll down and find where the association is with 'dot r' files and then select 'Open' - edit...

it should probably be set to something like

"C:\path to rebol\rebol.exe" "%1"

Sil
Reply With Quote
  #3  
Old 25-January-2002, 23:56
squidgy
Guest
 
Posts: n/a
Default

Thanks silv.

Before I tried your suggestion, I tried removing the association first, then double clicking a .r file and reassociating it with rebol.exe using the "Open With" dialog box that Windows opens up when you do this, but same thing happened, the Rebol interpreter would start but it wouldn't actually run the script I'd double clicked on.

But I put the "%1" after it and it works now. Why I've never needed this before is a mystery to me, and it's also a mystery why other file type associations don't have the "%1" yet they still work properly.

Reply With Quote
Reply

Tags
files, windows

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 17:04.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 1999-2014 The Scream!